Hindsight is 1024×768

Ever go through a bunch of “deep” steps in troubleshooting, only to realize the answer was right in front of you the whole time? This is my story.

files_inside_the_computer

While testing a new gui based app via RDP, I was presented with a warning prompt on app launch that cited a resolution requirement of at last 1024×768….My local display is at least this resolution, so Microsoft RDP should adjust accordingly. The app would launch as normal after clicking the sacred “ok” button. *scratch head* I need this warning to go away before testing/validation by said application owners.

My immediate reaction was to check the resolution. The drop-down was greyed out. I rebooted the box and was still unable to change the setting. After a quick google, I stumbled upon a KB article to increase the vRam size and tweak display settings at the hypervisor level…
VMware KB: “Adding video resolution modes to Windows guest operating systems”
After modifying the svga options in the vmx file and booting the vm back up…I was still unable to change the windows drop-down. This rules out any hypervisor based resource issue, I suppose.

At the bottom of the aforementioned KB, was another link/KB, aptly named “Increasing virtual machine display resolution to a custom resolution beyond the maximum resolution listed in Microsoft Windows” There is ACTUALLY a small utility that you can invoke, if and when display settings are unavailable in windows.

From an elevated command promot, I set it to my desired resolution and reboot.
VMwareResolutionSet.exe 0 1 , 0 0 1024 768
….STILL GREYED OUT

I sit back in my chair and stare at my screen for a moment and it dawned on me…. I have been testing the whole time using MS Remote Desktop Connection Manager and not the traditional RDP!

I connect using a normal RDP session and BAM!!! The app friggin works without prompt. The display settings are showing my resolution. Also, as NOW expected, the settings are greyed out.

RDP connection manager was forcing my display in it’s mirrored/server listing view mode and causing the issue the whole time. I learned some cool stuff about vmware, was reminded of some simple RDP display principles, but ultimately….

facepalm

Leave a Reply

Your email address will not be published. Required fields are marked *